PIL/Pillow

PIL is the Python Image Library. It was deprecated some time ago and Pillow is the successor. Neither package is part of Python’s standard library.

Errors

If pillow is not installed and you are running a Task that requires it, DropPy will show an error:

Error DropPy Alert screenshot

And the log file will show this:

Error Logfile PIL screenshot

Install the pillow Python package to get the Task working.

Installation

Since pillow is a very common package and therefor useful to have available globally we use sudo for installation. Run the following command in your Terminal:

sudo pip install pillow

If this worked you’re already done. If you get an error install pip first.

Checking if PIL/pillow works

In a shell the following command should run without displaying an error:

python -c "from PIL import Image"

If you get no output everything is ok.

If you get the following output pillow is not installed:

Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: No module named PIL

Uninstallation

Just for the sake of completeness.

pillow (and its dependency olefile) can again be removed with:

sudo pip uninstall pillow olefile

Resources